BoxUIElement3D.ToolTip is not displayed if this is a child of a ModelVisual3D
#3
Hi Abenedik,

thanks for the reply!

I found out that the events are not thrown when i add the rootTransform MainViewport before i add the UIElement3D objects to the rootTransform.


Exp.:

This works:       
Code:
           ModelVisual3D rootTransformModelVisual3D = new ModelVisual3D();
           Ab3d.UIElements.BoxUIElement3D box = new BoxUIElement3D();
           box.ToolTip = "am i visible?";
           rootTransformModelVisual3D.Children.Add(box);
->          MainViewport.Children.Add(rootTransformModelVisual3D);


This doesn't work:       
Code:
           ModelVisual3D rootTransformModelVisual3D = new ModelVisual3D();
->          MainViewport.Children.Add(rootTransformModelVisual3D);
           Ab3d.UIElements.BoxUIElement3D box = new BoxUIElement3D();
           box.ToolTip = "am i visible?";
           rootTransformModelVisual3D.Children.Add(box);


By the way:

You made a great framework!
Thanks

░░░░░░░░░░░░▄▄░░░░░░░░░
░░░░░░░░░░░█░░█░░░░░░░░
░░░░░░░░░░░█░░█░░░░░░░░
░░░░░░░░░░█░░░█░░░░░░░░
░░░░░░░░░█░░░░█░░░░░░░░
███████▄▄█░░░░░██████▄░░
▓▓▓▓▓▓█░░░░░░░░░░░░░░█░
▓▓▓▓▓▓█░░░░░░░░░░░░░░█░
▓▓▓▓▓▓█░░░░░░░░░░░░░░█░
▓▓▓▓▓▓█░░░░░░░░░░░░░░█░
▓▓▓▓▓▓█░░░░░░░░░░░░░░█░
▓▓▓▓▓▓█████░░░░░░░░░█░░
██████▀░░░░▀▀██████▀░░░░
  


Messages In This Thread
RE: BoxUIElement3D.ToolTip is not displayed if this is a child of a ModelVisual3D - by close - 03-09-2020, 04:34 PM

Forum Jump:


Users browsing this thread:
1 Guest(s)