Reader3ds licensing problem
Hello Andrej,

we have a problem with the license mechanism. Reader3ds is used by a DLL which in turn is loaded by an unmanaged application. So we have to put the license.licx into the DLL. This does not seem to work. When trying to access Reader3ds it complains about a missing license.
Strangely, the same setup works fine with ReaderWmf.
The generated licenses resource in the DLL looks fine to me.
Is this situation not supported by Reader3ds?

Regards, Klaus

P.S. ... and my best wishes for your new company!
For now, we "solved" it by launching a new process with managed executable (where the license is embedded) and communicating with it to perform the required functions.
I am glad that you solved the problem.

The Reader3ds is using quite old licensing code - ReaderWmf is using a newer code. In the new Reader3ds that will be released soon, the licensing code will be also updated.

Thank you for your best wishes :)
Andrej Benedik

Forum Jump:

Users browsing this thread:
1 Guest(s)