FBX animation problem
I try load the FBX animation through "Ab3d.PowerToys.Samples" but you can see the result.

At end of video you can see the correct animation of this model.
How to fix this?
PS. You can download the model by this link 

[Video: http://youtu.be/NxmKlDHXEq0]

PS. Ab3d.PowerToys version - 8.2.6863 ( 17 Oct 2018)
I have tried your file and see the problem.

After some investigation, I have found out that the problem is probably caused by assimp importer that for fbx files creates a few additional nodes that produce invalid animation (see also https://github.com/assimp/assimp/issues/894). Based on the recommendations on the web, I have tried to disable this with assimp importer (using AI_CONFIG_IMPORT_FBX_PRESERVE_PIVOTS setting) but this did not help. I have also tried to manually combine the nodes but this also did not help.

Because I currently work on some other things (multi-threaded rendering for DXEngine), I had to postpone this task and will work on it later.

So, sorry, for now there is no solution for fbx files. If you can, please try to save the animation into some other file format - maybe this will work better. I will notify you when this is fixed.
Andrej Benedik
Looks better with version 8.3.6989 but still unusable

Yes, some improvements were done to better connect bones to nodes from fbx animations (assimp importer adds some additional text to the name and this prevented correct connection before). But still this was not enough to correctly support your fbx files. Sorry, but I run out of time to work on this issue - this is planned for the future.
Andrej Benedik
This bug still don't resolved  in version 9.0.7115.

The skeletal animation problems have been finally fixed.

In the attached zip file are the cs files that should be extracted over the same files in the Ab3d.PowerToys Samples project.

Attached Files
.zip   Ab3d.PowerToys-SkeletalAnimationUpdate.zip (Size: 13.6 KB / Downloads: 2)
Andrej Benedik
I found your message just now.
This still doesn't work 

FBX file

[Image: https://drive.google.com/open?id=1uYbdyH...Yc06F54l8R]
You are right. It still does not work with an older native assimp importer.

You can get the latest version from https://github.com/assimp/assimp and compile it or download a precompiled version from our web site:

Attached Files Thumbnail(s)
Andrej Benedik
Now looks better.

But try also this file.

[Image: https://drive.google.com/file/d/14o-SPxq...sp=sharing]


Thank you!
I have checked your solider.fbx model and it is correctly animated in 3D Studio Max.
But when it is opened with assimp importer, the model is not correct.

I have checked the assimp GitHub site and found out that just a few days ago a new release of assimp library v5.0.0. was released. I have downloaded the source and compiled it.

But still, using the reference viewer that comes with assimp, the model is not correctly shown - see attached screenshot:


So we will need to wait for a fix in assimp importer.

Anyway, the compiled new assimp importer and new AssimpNet libraries can be download from (there is also an official assimp viewer):
Andrej Benedik

Forum Jump:

Users browsing this thread:
1 Guest(s)